./vrep:Error: could not find or correctly load the V-REP library

Typically: "How do I... ", "How can I... " questions
Post Reply
Zhuang
Posts: 9
Joined: 02 Aug 2017, 14:43

./vrep:Error: could not find or correctly load the V-REP library

Post by Zhuang » 04 Aug 2017, 12:30

$:ldd libv_rep.so
libqscintilla2.so.9 => not found
others all are found.
please ask how to deal with the problem
plus, $ ./vrep.sh , the order is ok

coppelia
Site Admin
Posts: 6218
Joined: 14 Dec 2012, 00:25

Re: ./vrep:Error: could not find or correctly load the V-REP library

Post by coppelia » 04 Aug 2017, 16:06

Hello,

is this with V-REP PRO EDU, or when you compile the source code yourself?

Cheers

Zhuang
Posts: 9
Joined: 02 Aug 2017, 14:43

Re: ./vrep:Error: could not find or correctly load the V-REP library

Post by Zhuang » 06 Aug 2017, 04:26

coppelia wrote:Hello,

is this with V-REP PRO EDU, or when you compile the source code yourself?

Cheers
thank your replay
yeah, its version is EDU. I just downloaded it and then started it on Ubuntu 16.04. But it did not work.
well, I found there are people who met the same problem, but there are no concrete solutions about the problem.
Cheers

coppelia
Site Admin
Posts: 6218
Joined: 14 Dec 2012, 00:25

Re: ./vrep:Error: could not find or correctly load the V-REP library

Post by coppelia » 06 Aug 2017, 12:14

if I download V-REP PRO EDU 3.4.0 into a fresh Ubuntu 16.04.2 64b LTS, I have no problem at all...

Zhuang
Posts: 9
Joined: 02 Aug 2017, 14:43

Re: ./vrep:Error: could not find or correctly load the V-REP library

Post by Zhuang » 08 Aug 2017, 13:26

coppelia wrote:if I download V-REP PRO EDU 3.4.0 into a fresh Ubuntu 16.04.2 64b LTS, I have no problem at all...
Thank your reply,
yeah, it is EDU 3.4.0.i installed it in another computer witch was good. but now I instill it my new computer witch does not work with $ ./vrep.
There were some people who met the same problem. But there is no solution.

Cheers

Zhuang
Posts: 9
Joined: 02 Aug 2017, 14:43

Re: ./vrep:Error: could not find or correctly load the V-REP library

Post by Zhuang » 08 Aug 2017, 13:26

coppelia wrote:if I download V-REP PRO EDU 3.4.0 into a fresh Ubuntu 16.04.2 64b LTS, I have no problem at all...
Thank your reply,
yeah, it is EDU 3.4.0.i installed it in another computer witch was good. but now I instill it my new computer witch does not work with $ ./vrep.
There were some people who met the same problem. But there is no solution.

Cheers

coppelia
Site Admin
Posts: 6218
Joined: 14 Dec 2012, 00:25

Re: ./vrep:Error: could not find or correctly load the V-REP library

Post by coppelia » 08 Aug 2017, 15:25

Not sure what the problem is. My best guess is that you do not have a fresh ubuntu installation or you modified your ubuntu in a way that causes problems with V-REP. What are the differences with the installation where V-REP ran fine?

Cheers

Zhuang
Posts: 9
Joined: 02 Aug 2017, 14:43

Re: ./vrep:Error: could not find or correctly load the V-REP library

Post by Zhuang » 13 Aug 2017, 11:56

coppelia wrote:Not sure what the problem is. My best guess is that you do not have a fresh ubuntu installation or you modified your ubuntu in a way that causes problems with V-REP. What are the differences with the installation where V-REP ran fine?

Cheers
I do not know what differences there are. I just wanna kill the problem.

coppelia
Site Admin
Posts: 6218
Joined: 14 Dec 2012, 00:25

Re: ./vrep:Error: could not find or correctly load the V-REP library

Post by coppelia » 16 Aug 2017, 07:58

..and I cannot test your system from here.
Also, instead of running

Code: Select all

ldd libv_rep.so
you should run

Code: Select all

./libLoadErrorCheck.sh
and inspect the output.

Cheers

Post Reply