Execute V-REP without GUI via ssh

Report crashes, strange behaviour, or apparent bugs
coppelia
Site Admin
Posts: 5316
Joined: 14 Dec 2012, 00:25

Re: Execute V-REP without GUI via ssh

Postby coppelia » 15 Jul 2016, 08:53

Jessica,

before transmitting it, you could save it to file (simSaveImage) to make sure that the vision sensor is operational. Remember that you should do this in the sensing section of a child script, otherwise you will retrieve the image from previous simulation step (and no image at all in the first simulation step). Unless you explicitely handle your vision sensor.

There is an example how to publish/subscribe to an image with the new RosInterface: rosInterfaceTopicPublisherAndSubscriber.ttt

Cheers

nehagarg
Posts: 6
Joined: 06 Mar 2015, 10:54

Re: Execute V-REP without GUI via ssh

Postby nehagarg » 22 Dec 2016, 12:01

Hi

I am also trying to run vrep in headless mode without GUI. I followed the solution in the post with xvfb-run and when I run the following command

xvfb-run --auto-servernum --server-num=1 -s "-screen 0 640x480x24" ./vrep.sh -h <scene name>

vrep is able to load all the plugins and start.

However as soon as I start simulation through ros api , vrep crashes with error: "Could not initialize OpenGL Aborted(Core Dumped)"

If I issue command xvfb-run --auto-servernum --server-num=1 -s "-screen 0 640x480x24" ./vrep.sh -h -s5000 -q <scene name>, then also vrep crashes immediately with the same error.

Is there a way to fix it?

Thanks.

Neha


Return to “Bug reports”

Who is online

Users browsing this forum: No registered users and 9 guests